Remove the undercuts from a 3D model with Blender

Dental3Dlugin has a built-in undercut removal feature. But under certain circumstances and until Dental3DPlugin 3.0, this feature didn’t work properly  and produced 3D models with errors. The UndercutRemove Add-on for Blender allows to remove the undercuts in such circumstances.

Installing Blender and the UndercutRemove Add-on

Download Blender.

Download the UndercutRemove Add-on for Blender (UndercutRemove.py file in a compressed folder).

Run Blender and open File > User preferences.

Under Add-ons, click on Install from File… Navigate to the UndercutRemove.py file you downloaded and select it.

The Add-on appears in the window. Tick the checkbox to enable it.

Click on Save User Settings to have the Add-on enabled every time you start Blender.

Using Blender and the UndercutRemove Add-On

Start Blender.

Delete the default Blender 3D cube by pressing ‘X’ or ‘Delete’.

Go in File > Import > Stl. to import your model.

Press ‘Shift + C’ (center) to see the model you have imported.

Navigating in the 3D space (more info on Blender help page)
Mouse drag to change the viewpoint.
Numpad ‘+’ and ‘-‘ to zoom-in / zoom-out or pad pinch on a MacBook (or wheel if you have a mouse wheel).
Numpad ‘1’ ‘3’ ‘7’ ‘9’ to change the viewpoint.

On a side view of the mode, press ‘R’ and move the mouse to set the model position. This will set the direction in which the add-on removes the undercuts.

Select the model with a right-click (the model must be outlined in orange).

Run ‘Object > Remove the Undercuts‘ in the menu bar under the 3D view or press the space bar and search the Add-on. The model should turn to green once the undercut removal process is finished.

Select ‘File > Export > Stl.‘ to export the new model. This model can now be imported in Dental3DPlugin as a new study or wax-up model.